Mushiboi_Bot Jumped Off A Cliff
Incident Report for Yoshiboi Development
Resolved
Fixed, have fun with him!
Posted Apr 20, 2021 - 13:35 EDT
Investigating
Mushiboi_Bot has gone down with the crew, don't know what the problem is, but we'll get it looked at sooner rather than later.
Posted Apr 19, 2021 - 08:49 EDT