Modershi_Bot is dead.
Incident Report for Yoshiboi Development
Resolved
Modershi_Bot is back up. Let's go!
Posted Apr 03, 2021 - 09:38 EDT
Investigating
We have noticed that Modershi_Bot is dead in your servers, and don't know what's happening. We at Yoshiboi_Development will find out what happened.
Posted Mar 27, 2021 - 14:23 EDT